agora inbox for pgsql-sql@postgresql.org
help / color / mirror / Atom feedFrom: Adrian Klaver <adrian.klaver@aklaver.com>
To: Sribeiro <info@simetriastudio.com>
To: pgsql-sql@postgresql.org
Subject: Re: Re: ERROR while creating new user - could not open relation mapping file global/pg_filenode.map
Date: Thu, 3 Dec 2015 08:48:53 -0800
Message-ID: <56607275.4060404@aklaver.com> (raw)
In-Reply-To: <1449160418085-5876161.post@n5.nabble.com>
References: <1449100566874-5875998.post@n5.nabble.com>
<565F8951.7090505@aklaver.com>
<1449102851217-5876007.post@n5.nabble.com>
<565F8F44.2060200@aklaver.com>
<1449103913630-5876012.post@n5.nabble.com>
<565F9916.8050800@aklaver.com>
<1449107178100-5876028.post@n5.nabble.com>
<565FCD37.3080804@aklaver.com>
<1449147608774-5876118.post@n5.nabble.com>
<566060E1.6070808@aklaver.com>
<1449160418085-5876161.post@n5.nabble.com>
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-sql>
On 12/03/2015 08:33 AM, Sribeiro wrote:
> 1) yes, I have a fresh install from yesterday in the /usr/local/var/postgres
> directory. Yesterday there was no server.log in that directory, but today I
> have a server.log in that directory. There's only one timestamp:
> /LOG: database system was shut down at 2015-12-02 16:33:52 EST
> LOG: MultiXact member wraparound protections are now enabled
> LOG: autovacuum launcher started
> LOG: database system is ready to accept connections/
>
> 2) Yes, but only one server.log file with many entries/timestamps that
> includes the timestamp mentioned previously.
>
> 3) Here is the path to the directory where the older server.log resides -
> /Users/Serge/Desktop/postgres
>
> 4) Both installs have the pg_filenode.map inside the global directory, but
How can that be?
From previous posts:
"
Dec 02, 2015; 1:06pm Sribeiro Sribeiro
This is what that directory looks like - http://postimg.org/image/olhb2zra9/
I can't find anywhere on my system (doing a search) the .map file.
Thank you for clarifying the importance of that file.
Since I didn't have any important information on it, can I start from
scratch, and thus creating a new .map file?
Sergio
Dec 02, 2015; 1:44pm Sribeiro Sribeiro
This post was updated on Dec 02, 2015; 1:45pm.
Hi Adrian,
So, i made sure to copy the postgres directory then deleted the main one
as to not conflict with a fresh install.
Once I got to the section in the instructions I used that says to run
the - rake db:create:all
I get the following error:
rake db:create:all
FATAL: could not open relation mapping file "global/pg_filenode.map":
No such file or directory
BUT, if I look in the newest postgres/global directory, the
pg_filenode.map is in there.
Any thoughts
Sergio
"
Are you sure /Users/Serge/Desktop/postgres is not a link to somewhere?
> when I ran the commands from yesterday, I kept getting the error message:
> /psql: FATAL: could not open relation mapping file
> "global/pg_filenode.map": No such file or directory /
Have you tried stopping Postgres and then restarting it?
>
>
>
> --
> View this message in context: http://postgresql.nabble.com/ERROR-while-creating-new-user-could-not-open-relation-mapping-file-glob...
> Sent from the PostgreSQL - sql mailing list archive at Nabble.com.
>
>
--
Adrian Klaver
adrian.klaver@aklaver.com
--
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql
view thread (52+ messages) latest in thread
Message-ID: <56607275.4060404@aklaver.com>
Permalink: ../56607275.4060404@aklaver.com/
Also on: postgresql.org/message-id/56607275.4060404@aklaver.com
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-sql@postgresql.org
Cc: adrian.klaver@aklaver.com, info@simetriastudio.com
Subject: Re: Re: ERROR while creating new user - could not open relation mapping file global/pg_filenode.map
In-Reply-To: <56607275.4060404@aklaver.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox